Скачать Joomla 2.5 и как обновить Joomla 1.7 до Joomla 2.5

Полезное для Joomla


Скачать Joomla 2.5 и как обновить Joomla 1.7 до Joomla 2.5

Здравствуйте дорогие друзья и любители Joomla. Вот и пришел тот час, когда была выпущена новая версия нашей любимой CMS Joomla 2.5 (Joomla 1.7 уходит в прошлое). В этом посту я предлагаю вам скачать Joomla 2.5 и обновить Joomla 1.7 до Joomla 2.5, а также почитать, что же изменилось и что новенького в свежей версии CMS Joomla 2.5. Забегая на перед хочу напомнить, что Joomla 2.5 по сути это продолжение версии Joomla 1.7, по этому обновление до новой версии довольно простое и поддержка версии Joomla 1.7 закончится в следующем месяце.

А начнем мы наверное с того, что посмотрим что новенького появилось в версии Joomla 2.5:

  • Новый компонент расширенного поиска по сайту
  • Поддержка сторонних баз данных (Microsoft SQL , Postgresql)
  • Автоматические уведомления о обновлениях, как для самой Joomla 2.5, так и сторонних расширений
  • Плагин для поддержки reCAPTCHA в Joomla 2.5
  • Возможность создавать модуль меню прямо из списка имеющихся меню в системе
  • Возможность задавать стили форматирования для каждой статьи Joomla 2.5
  • Возможность выбрать, нужно ли уведомление на почту когда регистрируется новый пользователь
  • Дополнительное поле в пункте меню для заметки (напр. зачем именно он нужен и т.д)
  • Фильтр выбора статей по категориям и под категориям в менеджере материалов
  • Возможность указывать картинку к надписи, когда сайт закрыт
  • Указание мета-тегов для каждого языка в многоязычном сайте

и много других мелких фишек.

Скачать Joomla 2.5 и как обновить Joomla 1.7 до Joomla 2.5

Скачать Joomla 2.5

Скачать Joomla 2.5

Скачать полный релиз для установки CMS Joomla 2.5 с нуля вы можете здесь. Также по этой ссылке вы сможете скачать и пакет обновлений для своей Joomla 1.7.x, если вы захотите перейти на Joomla 2.5 вручную.

Как обновить Joomla 1.7 до Joomla 2.5

Для обновления Joomla 1.7.x до версии Joomla 2.5 есть 2 способа:

  1. По ссылке выше скачиваем пакет обновлений (файл называется Joomla2.5. updates) и через менеджер установки устанавливаем этот пакет, как обычное расширение.
  2. Делаем ряд следующих процедур:
  • Выбрать пункт меню «Сайт-Обслуживание-Очистить весь кэш» и удалить весь кэш
  • Выбрать пункт меню «Сайт-Общие настройки» и отключить кэширование
  • Выбрать пункт меню «Расширения->Менеджер расширений»
  • В Менеджере расширений выбрать пункт «Обновление»
  • На панели кнопок нажать кнопку «Очистить кэш»
  • На панели кнопок нажать кнопку «Найти обновления»
  • В списке найденных обновлений Joomla выбрать строчку с требуемой версией и нажать кнопку «Обновить»
  • После обновления необходимо очистить кэш браузера, так как JavaScript и CSS файлы могут быть закэшированы браузером

Напомню, что перед обновлением обязательно сделайте копию базы данных и файлов сайта, чтобы при случае неудачного обновления, вы смогли восстановить работу сайта.

Также хочу вам напомнить календарь планов разработчиков CMS Joomla на будущее:

  • 24 февраля 2012 — Завершение поддержки Joomla 1.7
  • Апрель 2012 — Завершение поддержки Joomla 1.5
  • Сентябрь 2012 — Выпуск следующей версии Joomla

Я думаю вы понимаете, что даты приблизительные, так как в данном деле могут случиться разные задержки.

А на этом пост Скачать Joomla 2.5 и как обновить Joomla 1.7 до Joomla 2.5 завершен. Желаю вам удачно обновиться до последней версии Joomla 2.5. Увидимся.

Joomla Блог Nauca – научись работать с Joomla

Хочешь получать на e-mail свежие статьи о компонентах, модулях, плагинах и других полезных вещах связанных с Joomla? Не пропусти ничего полезного, подпишись на новости блога Nauca:

  • Ну наконец то

  • Сходу так не скажу, нужно смотреть что пишется в этом файле.

    • разобрался, это логи от плагина Linkr. Забыл отключить логи и за год в папке логов от этого плагина целый Гиг информации собралось!

  • Crack241

    Сделайти пожалуйста SocComments под Virtuemart. Очень,очень большое пожалуйста.

  • Elan_555

    У меня не получается обновить пишет ошибку

    Warning: require_once(/home/****/public_html/libraries/cms.php) [function.require-once]: failed to open stream: No such file or directory in /home/*****/public_html/administrator/includes/framework.php on line 41

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/*****/public_html/libraries/cms.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/**/public_html/administrator/includes/framework.php on line 41

    • Проверте правильно ли у вас установлены права на папки.

  • Дмитирй

     Почему то после обновления дж 1,7 до  2,5 пропал пункт  «сайт —> общие настройки». Как это исправить?

  • Вадим

    Привет!!! Подскажити такой вопрос! Поставил eSport 1.7 вместе с Virtuemart Руссифицировал и перевел сайт на русский язык. И товары пропали и не добавляются… куда копать где может быть проблема????

    • Сложно сказать. По твоему описанию, одно с другим вообще не связано. Товары просто так не пропадают.

  • Romamus79

    Подскажите пожалуйста . Через менеджер расширений пытаюсь сделать joomla upgrate с 1.7 на 2.5 выдает такую ошибку.Ошибка загрузки файла на сервер. 

    Невозможно найти установочный пакет.

    в чем может быть проблема?

    • Возможно у вас стоят некорректные права на папки, вот файл и не может сохраниться

  • Kalibri9

    Помогите! при обновлении версии 1,7 на версию 2,5,6 выедет ошибку 500 … Что делать?

    • Это проблемы с настройками сервера. Попробуйте увеличить время ожидания.

  • ащк

    Спасибо